Sunday, 27 July 2008

Now Playing 4.04 (beta)

Download

This version is for people who have trouble with iTunes or Foobar not updating. I've changed a few things in the code that may or may not help, unfortunately as I can't reproduce this issue it's difficult to fix it. If you still have trouble, in the settings there's a new option "Enable failsafe". This option will refresh the gadget every 30 seconds and check if the track has changed manually.

Let me know how things go and report any problems in the comments below.

77 comments:

rob said...

this has definitely made an improvement. i just found your gadget and then experienced the problem you were talking about. found your blog and the beta fix. Definitely see an improvement in updating on foobar2000

rob said...

sorry for the second comment i cant edit the first... could you also see if you can get the random feature to work. every time i select my tracks to play random in foobar this gadget changes the play option to regular.

Gantry said...

Still having the switching problem with Foobar 0.9.5 - uninstalled all the old versions, installed this one and it lasted about 5 songs before it stopped switching the art.

"Enable failsafe" also didn't work. When I enabled the option, it switched the song immediately. After that, even though it is still checked, the art is no longer switching.

Gantry said...

As another update - when the switching stops working checking OR unchecking "enable failsafe" switches the art immediately after clicking OK. After that it longer switches until you check or uncheck "enable failsafe"

Law James said...

Are you leaving it long enough? The failsafe is only every 30 seconds.

Gantry said...

I let it run for a good 6-8 minutes and even let it switch between multiple songs to make sure. Nothing switches, yet enabling or disabling that option changes the album art immediately for that particular song. After that, no more switching

Gantry said...

Just installed it on my home machine and got the same results - stops switching art after a few songs and failsafe (checked or unchecked) only works for one song.

Law James said...

I guess this may be down the the plugin then as I've done everything i can on my end. It's much easier getting the gadget to work with players that have real scripting APIs like WMP, iTunes and MediaMonkey, but Foobar is all jumbled and there's no native Scripting support.

As a side note when I used to have Foobar installed for testing purposes track changing worked and it also worked for the people who test the gadget so it does appear to be affecting some users and not others (as opposed to all users).

Anonymous said...

I beleive the problem with iTunes lies somewhere in the now update to 7.7, ever since I was notified of the new version, the gadget hasn't worked, and the failsafe didn't help and

Anonymous said...

sorry, new update**

Anonymous said...

Great gadget. Thanks a lot, but for some reason I cannot change skins. Tried all v. 4.x. without luck. Using WMP on Vista SP1.

Greg said...

I have the iTunes 7.7 problem. None of the sidebar iTunes gadgets work after upgrading to 7.7.

missgoober said...

yeah i have the same problem with the update of itunes

Anonymous said...

Hi Law, any chance you would consider supporting SongBird?

Law James said...

Hi,

I can take a look into it as it looks like they now have a Javascript API. Do you work for SongBird?

Anonymous said...

I tried this, and now my iTunes starts freezing all the time....

Anonymous said...

The 30 seconds solution works for me, it is a life saver!!

I am using iTunes 7.7 on Windows XP

I prefer setting the failsafe time for at least 10 seconds. Sometimes it is really annoying waiting for a song for up to 30 seconds to show its cover art, 30 seconds is a considerable amount of songs which are in average of 3:30 nowdays.

If you give us the option to set the amount of seconds that would be perfect!

Stephen Furr said...

I'm running iTunes 7.7.1.11 (I think, I had to close the sidebar altogether to get to iTunes to get to About...

When the gadget is running, iTunes is totally unresponsive. It plays songs fine, and skips to the next song and updates the cover art in the gadget perfectly. Problem is that I can't get iTunes to minimize, restore, maximize or close. Even when I have iTunes up, I can't DO anything in iTunes directly. Is this by design? When I try to close iTunes, it complains that something is preventing it from closing (the gadget.) If I say close anyway, it closes and immediately reopens.

BTW, this is on Vista Ultimate 32-bit.

For now, I've had to remove the Now Playing gadget.

Hope this helps and I'll keep checking back for updates.

Stephen

Law James said...

With regards to iTunes being unresponsive, there's no API calls I use to tell iTunes to break, I just use the calls laid out in the documentation. It does seem that for whatever reason some people have very varied and sometimes major issues with iTunes, and for others (including me) it works absolutely great.

With regards to the closing of iTunes, you have to use the close button in the gadget, there's an icon on the top right of the gadget, not the button to close the gadget, it's within the gadgets border.

plattze said...

Hi,

When it loads and I click foobar's icon, it displays:

Notice:
Error
Downloading Plugin


Any ideas? Vista (Admin Account, UAC Off, Norton N360).

I've tried with N360 fully disabled.

Thanks

Law James said...

Read the readme, in there near the bottom theres something about how to download the plugins manually.

Antonio said...

This is pretty cool. Do you have Songbird support coming along? I will cry tears of joy if it's coming up next.

Law James said...

I took a brief look and couldnt find a good API I could use unfortunately.

Y1n_X1 said...

I am also in favor of songbird support. I don't work for them but I do use it as my main music player and can't seem to find any now playing type gadget that can support songbird. It would be greatly appreciated if you added songbird functionality.

Andrew said...

Any news on a new Version off this mate =]?

Bilal said...

I'd also like to request support for Songbird. I've recently made the switch from iTunes to the bird and I really love it.
Thanks!

Law James said...

As I said earlier, there is no API I can use. It doesn't matter how many people express they want this, it's not possible.

Pazuzu said...

Any chance to add AIMP 2 support?

Anonymous said...

Now there is new iTunes 8.0 and the Now Playing Gadget is completely not working with it!

:(((((

Bryan Karas said...

thanks for this gadget, it's my favorite.

i've also had the same iTunes problem, both with 7.7 and now with 8.

i've tried reinstalling the gadget, and reinstalling itunes, no luck.

from the "choose a player" dialog, i click on itunes, then it displays the iTunes icon as if iTunes wasn't open. i click on it, it opens iTunes, but then nothing... just the iTunes icon.

any thoughts? i really appreciate your work on this... wish i knew some programming.

Vista 32, all updated and clean.

Bryan Karas said...

oh... it's not just your gadget... any itunes gadget i try has the same "doesn't realize iTunes is running" behavior.

thanks again!

Bob said...

Hi Law, the NowPlaying gadget is awesome if it works properly - but I've had the exact same issue & symptoms as gantry says in his comments.

Am running foobar2000 v0.9.5.6 with the NP 4.04 beta on a Vista Ultimate 32-bit install.

I still hope you can get it fixed, because NP more or less has lost its functionality for me because of the no-update issue.

Anonymous said...

Nice Program, the only bad thing is that the lyrics-window closes when you click on another window.

Anonymous said...

When will you be releasing the next version. With new itunes versions NowPlaying freezes itunes for minutes at a time. Thanks...

Monkeyuser said...

There seems to be a problem regarding MediaMonkey. When i try to exit the application a message appears about a COM port and such. This appears every time i press the exit button in MMonkey and is quite annoying to have to click on the message every single time.
Is there anything you can do about it maybe?

Ps. Screenshot uploaded.
http://img515.imageshack.us/img515/7797/mediamonkeyproblemuj6.jpg

Law James said...

Use the close button in the top right of the gadget. Or if the gadget is docked click menu and then click quit player.

soddit112 said...

evening all,

does anyone else get a whole flurry of avast! anti-virus warnings when downloading and installing this gadget? i dont mean to imply anything at all, though it is a bit worrying to say the least. im running it regardless of the warnings and nothing seems to be amiss so it appears to be a false positive, though i could do with some reassurance its not going to suddenly spew gremlins all over my PC ;P

Law James said...

There was some comments about this before, may have been Avast or a different AV. It was because the AV doesn't know the difference between a website and a gadget. The issue should have been fixed by the AV people but apparently it hasn't been.

Anonymous said...

Will you be releaseing a next version? itunes freezes will playing songs, songs continue but can't navagate w/i itunes while gadget is running. I'm not talking about trying to close itunes but navagating w/i it. Thx...

Law James said...

Probably not, I don't have the time to spend diagnosing issues that occur as a result of iTunes being updated, my gadget used to work fine with iTunes (and still does for me) but users now report a multitude of issues which I don't see anyway to fix. I suggest you either use WMP or try another iTunes gadget (I'd be really interested to hear if using another iTunes gadget fixes your issues).

As a side note, there's no known issues with WMP.

Anonymous said...

itunes Accessory works fine but no "lyrics" option. Do you have a link to older verion of NowPlaying?


Thx...

Anonymous said...

I get an alert from Avast, too. Not willing to test if it's a false positive :P

I will send the file to avast so they can check ...

Anonymous said...

First i would like to thank you for this cool gadget. Then.... i have vista Ultimate 64bits and can't make your plugin show me the album cover, media player works well... but media monkey shows nothing, any leads?
thanks in advance!!!

Anonymous said...

@last anonymous (15 October 2008 05:22):
Make sure you're running the 32 bit version of the sidebar, I find that fixes pretty much all compatibility issues with a lot of plugins. Here's a page with instructions: http://adamkinney.com/blog/323/default.aspx I'm using 32 bit sidebar on Vista 64 bit with this gadget and MediaMonkey v. 3.0.3.1183 and all functions are working fine.

@law james:
[see next paragraph for update]
Could you explain how the gadget I have is version 4.05 when official download is version 4.0 and your blog latest version is a beta 4.03? In the "About" tab of the gadget configuration it says "Version: 4.0" but is reported as version 4.05 when viewing 'sidebar properties' -> 'list of running gadgets'. Today I downloaded version 4.0 from the Windows Live Gallery, and that reports as version 4.0 under 'sidebar properties' - 'list of running gadgets'.

... Interesting. I was going to post the two locations where I downloaded the gadget from on July 29th 2008. I decided to see if either location actually currently hosted the 4.05 version. So I redownloaded and reinstalled both of them. Being lazy and not wanting to uninstall/install I just installed all 3 at the same time. So the original 4.05 was already installed and I installed the first redownloaded copy. With both installed, there was listed both 4.0 and 4.05. I then installed the second redownloaded copy. With all three installed, there was listed three 4.0s, no 4.05. I then uninstalled all three, restarted sidebar, and reinstalled the 4.05 version, except now it reports as 4.0. I uninstalled/reinstalled the 4.05 version again, same result, now reports as 4.0. Very strange.

Now I really have no idea what the deal was. Was there ever a 4.05 version before July 29th 2008? If not why would it report that? I uninstalled the 4.05 version, installed the 4.0 version I downloaded today from this site, and then reinstalled the 4.05 version, and it still reported as 4.05. It was not until 3 separate copies were installed at the same time that it started and continues to now report as 4.0. Any idea on why?

Law James said...

I have a 4.05 on my machine dated 27/07, the 4.04 blog post is dated 27/07 also so maybe I got confused with the versioning or something.

Either way, upgrading above 4.0 will probably only affect you if you're using foobar/winamp/itunes.

MuhdHusaini said...

Hye just want to know why is the pic of the song and the song is not change even the song in my winamp has change but in now playing still not change still show the old song...

Anonymous said...

With regard to the media monkey issues about closing and "COM servers"
you response "Use the close button in the top right of the gadget. Or if the gadget is docked click menu and then click quit player."

This does not work with my VHP install, I'm running mm 2.5.5

I have tried to find my old version (no issues) but been unable to...

Do you keep all the old versions?

If so could you please host/post them some where...

Rob

Law James said...

I do have old versions, but that wont help you. I've never changed the way NP closes MM. It's not the gadgets faulty that MM pops up with the warning, my gadget doesnt tell it to do so, it's MMs choice.

Bryan Karas said...

So... i ended up doing a clean install of Vista because of some other issues, and Now Playing is working again! Whoo-hoo!

Thanks so much... it's one of the most useful little tools on my computer.

Andrés said...

I have an issue with this gadget, it doesn't works for me, it was working very well but sudenlly stop working. It only shows a white rectangle in the sidebar and doesn't let me change the options. Please, help, this is my favourite gadget, what can I do?

Bjørn Tore said...

Any chance you can support VLC Media Player in addition?
Bjørn Tore

Laimis said...

Old Winamp
Many users still using Winamp 2.95 because it is lighter. Will it be possible to add Winamp 2.x support? It shouldn't be to difficult..looking forward..

Lev Kurbanyan said...

I have the same issue as Bryan Karas above. None of the iTunes gadgets seem to recognize or control iTunes. Now Playing only shows the icon. The only thing that works is clicking on that icon that opens up iTunes but that's it. Is there any other solution than a clean install of Vista?

Law James said...

I beleive many people have had success simply by re-installing iTunes. Personally I wouldn't both re-installing Vista because Apple can't be bothered to make their software work well on Windows.

Daniel said...

I'm using vista64 with winamp 5 and always get an error message when choosing the plugin: "error when activating winamp plugin"

What can I do to make it work, do I have to install a different plugin into winamp?

Nasir said...

Could you add Zune software support? I would really like to use this with it.

pavlos_stam said...

I just saw that when i click options nothing happens, and after 1 minute the options tab revealed!
this is very strange , you have to wait long time for that.

시노루 said...

If the song doesn't have tag, It doesn't know winamp is playing the song.

erServi said...

Well, i've tried both versions of Now Playing. The "good" one freezes and doesn't refresh except i press "next" or "previous" in the gadget... (it's not enought to hover the mouse a while over the gadget)

The 4.0.4 beta version makes the sidebar spend a lot of memory and finally freezes it.

So i prefer tha alpha version. It works better except the refresh issue... (plase, fix it, i can't live without this gadget!)

(I have installed the original vista sidebar in my xp sp3)

(sorry for my poor english!)

erServi said...

I've forgot to say that i'm using iTunes, of course!

Law James said...

Your problem is two-fold, the main issues is that your using iTunes, which is the reason sometimes it stops updating, it hasn't frozen, iTunes has just decided to stop talking to it.

Your second issues is your using a sidebar designed for Vista on an OS that doesn't support it, that's why the sidebars crashing.

Afraid there's nothing I can do to fix it.

Anonymous said...

Hello, is it possible to add AIMP2 support please?

Anonymous said...

I am using the gadget with last.fm. The issues I am having is that it shows the previous song played rather than current. Also i can't minimize image to fit side bar so i have resorted to just text.

Law James said...

Thats how last.fm works, it's not supposed to be live, it only submits the data to last.fm half way through the song and then the gadget only checks every so often.

Tsuki said...

foobar 9.6.3 without any addons, windows 7 7068, seems to work fine.

Tsuki said...

update: updates are random, sometimes failing, even with a folder.jpg present. once in a while it'll crash both foobar and the gadget during the first playback on system reboot, but after that won't crash unless i try and resize it manually with the resize button.

BaiLeY said...

I am currently using winamp 5.5 and 4.04 of the gadget. It shows "Error Activating Winamp Plugin". What do I need to fix this?

Law James said...

Click the "open gadget folder" link in the settings, go to the plugin page and launch NPWInamp plugin or whatever its called. Or if its not there maybe your AV or Firewall is blocking it, if so download the plugins from the bottom of the readme file.

BaiLeY said...

Thank You for the prompt response. That definitely helped. It works now!

Chris Lynch said...

Will you be able to support WMP12 anytime soon? I can offer a small donation for beer and pizza! Or, something else.

Law James said...

Doesn't it already support WMP12? I use it on Win7. It obviously won't work on the X64 WMP12 on X64 though, but you can use it in the X86 WMP12 on X64

Chris Lynch said...

Doh! I use the 64-bit Media Player, not 32-bit.

migue said...

Is anyone else having an issue if using the "always big" layout with a zoom level other than 1 where the border shadows are pink. I started having this problem ever since I upgraded to IE8.

Nicolas said...

Hi, I were using your gadget until i switch to Songbird.

Please, if you can add support for it will be great :)

Matt said...

Great gadget, only problem is coverart aspect ratio.

CalumJR said...

I also see an improvement since using the "Enable failsafe" option.

May I just say, this gadget does EVERYTHING I wanted a music gadget to do better than any music gadget I've ever used. Thank you very much :)

I just need to find a way to get it to show the artwork of the file from my library rather than from wherever it gets the artwork from as a lot of the artwork it gets is different to what is in my library.

Nevertheless, thank you very much for your hard work and for maintaining this gadget so well and so often! It is much appreciated!

Cadmiel said...

Can you add AIMP2 in the package please??? Please!!

Your tool is great. Congratulations!